Root access possibly lost

  • Réponses :21
  • OuverteNon stickyRépondu
  • Posts de Forum 16

6 déc. 2014 15:33:27 via site

Bonjour,
J'ai essayé de flasher une rom pour mon galaxy s4 en suivant un tuto (impossible de mettre le lien), mais ça n'a pas marché, et j'ignore pourquoi.... Mon tel démarre seulement en recovery (cwm) et il m'indique que j'aurais perdu mon accès root. Il me propose de réparer mais ça ne marche pas....
Si l'un de vous a une solution je suis preneur svp... Merci d'avance :)

  • Posts de Forum 16

6 déc. 2014 15:52:06 via site

Cyanogenmod 12 unofficial

— Modifié le 6 déc. 2014 15:52:20

  • Posts de Forum 16

6 déc. 2014 15:57:11 via site

Dans un premier temps, puis ensuite cwm ( c'est celui que j'ai en ce moment)

Compte désactivé
  • Mod
  • Posts de Forum 1 670

6 déc. 2014 15:59:43 via site

Excusez ces multiples questions mais je dois un peu voir ce qui a été fait et ou vous en êtes :)

Alors avez-vous encore les fichiers de la ROM + GAPPS sur votre SD?

Njat njet njet boljse njet blatnova kriminala (kriminal)
-Crayon-
Veni Vidi Blocki -> By Quentin
https://www.youtube.com/watch?v=c94nySKKoWE
https://www.youtube.com/watch?v=RyxREU1J5Rw&feature=youtu.be

Compte désactivé
  • Mod
  • Posts de Forum 1 670

6 déc. 2014 16:03:14 via site

Alors commençons par un petit:

  • Wipe Data / Factory Reset
  • Wipe cache
  • Wipe Dalvik

Ensuite, flashez la ROM + les GAPPS.

Si vous rencontrez une erreur pendant la procédure du flash de la ROM, pouvez-vous me rapporter le message?

Merciii

Njat njet njet boljse njet blatnova kriminala (kriminal)
-Crayon-
Veni Vidi Blocki -> By Quentin
https://www.youtube.com/watch?v=c94nySKKoWE
https://www.youtube.com/watch?v=RyxREU1J5Rw&feature=youtu.be

  • Posts de Forum 16

6 déc. 2014 16:13:33 via site

Je n'ai pas de Wipe Dalvik dans mon recovery
J'ai tout de même pu faire les 2 premiers mais l'installation ne marche toujours pas

assert failed: run_program ("/bin/sh, "/system/etc/loki.sh") ==0
E: Error in /storage/sdcard/cm-12--20141203-UNOFICIAL-jflte.zip
(status7)
Installation aborted.

  • Posts de Forum 16

6 déc. 2014 16:14:34 via site

Je ne sais pas si ça a un rapport mais quand je démarre mon recovery il semble ne pas pouvoir monter et accèder à "/cache"

Compte désactivé
  • Mod
  • Posts de Forum 1 670

6 déc. 2014 16:23:40 via site

Lucas B.

Je n'ai pas de Wipe Dalvik dans mon recovery
J'ai tout de même pu faire les 2 premiers mais l'installation ne marche toujours pas

C'est dans Advanced.

Njat njet njet boljse njet blatnova kriminala (kriminal)
-Crayon-
Veni Vidi Blocki -> By Quentin
https://www.youtube.com/watch?v=c94nySKKoWE
https://www.youtube.com/watch?v=RyxREU1J5Rw&feature=youtu.be

  • Posts de Forum 16

6 déc. 2014 16:29:00 via site

Ah oui en effet désolé ^^
J'ai fait la manip et tenté de reflasher: même message d'erreur

Est ce que reflasher une rom officielle via odin pourrait régler le problème? Parce que je commence à avoir peur pour mon S4 et je pourrais patienter pour le mise à jour...

— Modifié le 6 déc. 2014 16:32:21

Compte désactivé
  • Mod
  • Posts de Forum 1 670

6 déc. 2014 16:39:01 via site

Oui, via Odin vous reviendrez au début. Mais cela vaut peut-être le coup de tenter cette ROM.

L'erreur du status 7 peut-être solutionnée comme ceci:

Télécharger et installer NotePad++ sur votre PC
Ouvrir le fichier updater-script qui se trouve dans l'archive cm-12--20141203-UNOFICIAL-jflte.zip, en suivant ce chemin: \META-INF\com\google\android\updater-script et supprimer toutes les lignes se trouvant avant le premier "mount".

Refermer l'archive, l'envoyer sur le téléphone et retenter le flash.

Njat njet njet boljse njet blatnova kriminala (kriminal)
-Crayon-
Veni Vidi Blocki -> By Quentin
https://www.youtube.com/watch?v=c94nySKKoWE
https://www.youtube.com/watch?v=RyxREU1J5Rw&feature=youtu.be

  • Posts de Forum 16

6 déc. 2014 16:53:20 via site

Il n'y a qu'une seule ligne et elle semble concerner mon numéro de modèle il y a des i9505 partout, est ce normal?

Compte désactivé
  • Mod
  • Posts de Forum 1 670

6 déc. 2014 17:01:45 via site

Oui, supprimez tout ce qui se trouve avant "mount"

Moi avant mount j'ai ça:

assert(getprop("ro.product.device") == "jflte" || getprop("ro.build.product") == "jflte" || getprop("ro.product.device") == "jfltexx" || getprop("ro.build.product") == "jfltexx" || getprop("ro.product.device") == "i9505" || getprop("ro.build.product") == "i9505" || getprop("ro.product.device") == "GT-I9505" || getprop("ro.build.product") == "GT-I9505" || getprop("ro.product.device") == "jgedlte" || getprop("ro.build.product") == "jgedlte" || getprop("ro.product.device") == "i9505g" || getprop("ro.build.product") == "i9505g" || getprop("ro.product.device") == "GT-I9505G" || getprop("ro.build.product") == "GT-I9505G" || getprop("ro.product.device") == "jfltevzw" || getprop("ro.build.product") == "jfltevzw" || getprop("ro.product.device") == "jfltespr" || getprop("ro.build.product") == "jfltespr" || getprop("ro.product.device") == "jflterefreshspr" || getprop("ro.build.product") == "jflterefreshspr" || getprop("ro.product.device") == "jfltetmo" || getprop("ro.build.product") == "jfltetmo" || getprop("ro.product.device") == "jfltecri" || getprop("ro.build.product") == "jfltecri" || getprop("ro.product.device") == "jfltecsp" || getprop("ro.build.product") == "jfltecsp" || getprop("ro.product.device") == "jflteatt" || getprop("ro.build.product") == "jflteatt" || getprop("ro.product.device") == "jfltecan" || getprop("ro.build.product") == "jfltecan" || getprop("ro.product.device") == "jflteusc" || getprop("ro.build.product") == "jflteusc" || getprop("ro.product.device") == "jfltezm" || getprop("ro.build.product") == "jfltezm" || abort("This package is for device: jflte,jfltexx,i9505,GT-I9505,jgedlte,i9505g,GT-I9505G,jfltevzw,jfltespr,jflterefreshspr,jfltetmo,jfltecri,jfltecsp,jflteatt,jfltecan,jflteusc,jfltezm; this device is " + getprop("ro.product.device") + ".");.);
run_program("/sbin/busybox",

Njat njet njet boljse njet blatnova kriminala (kriminal)
-Crayon-
Veni Vidi Blocki -> By Quentin
https://www.youtube.com/watch?v=c94nySKKoWE
https://www.youtube.com/watch?v=RyxREU1J5Rw&feature=youtu.be

  • Posts de Forum 16

6 déc. 2014 17:07:26 via site

J'ai la même chose sauf que tout est en une seule ligne
Ca n'a pas marché mais il est possible que j'ai fait quelque chose de mal: est ce que il faut décompresser complètement ma rom pour modifier le updater-script ou bien faut il faire autrement?

  • Posts de Forum 16

6 déc. 2014 17:12:26 via site

Je crois que c'est ça: j'ai décompressé ce que j'ai essayé de flasher et la première ligne du updater-script y est toujours, je ne vois pas commment la supprimer, le seul moyen de l'ouvrir est de décompresser complètement ma rom, mais comment la recompresser? La recompresser en .zip suffit?

— Modifié le 6 déc. 2014 17:27:13

  • Posts de Forum 16

6 déc. 2014 18:20:08 via site

Ca ne marche pas, cette fois ca me met juste "installation aborted", donc je pense que c'est du à une erreur de ma part non? Quand je décompresse l'archive il me demande si je dois remplacer certains fichiers, je mettais skip mais ce n'étais peut etre pas la bonne solution...

Compte désactivé
  • Mod
  • Posts de Forum 1 670

6 déc. 2014 18:27:25 via site

En fait il faut valider le remplacement car tu as fait une modification. Et c'est précisément ça qu'on veut dans l'archive, la modification pour passer l'erreur status 7.

Njat njet njet boljse njet blatnova kriminala (kriminal)
-Crayon-
Veni Vidi Blocki -> By Quentin
https://www.youtube.com/watch?v=c94nySKKoWE
https://www.youtube.com/watch?v=RyxREU1J5Rw&feature=youtu.be